ERROR: Interceptors are not working.

Discussions regarding ARGoS bugs. Report bugs here.
eptap
Posts: 9
Joined: Mon Sep 18, 2017 9:35 pm

Re: ERROR: Interceptors are not working.

Postby eptap » Sun Sep 24, 2017 3:28 pm

My apologies, I did what I did because of the following:

537 sudo rm -r build/ && sudo rm -r experiments/
538 ls
539 git clone https://github.com/ilpincy/argos3-examples
540 ls
541 cd argos3-examples/
542 mkdir build
543 cd build/
544 cmake -DCMAKE_BUILD_TYPE=Debug

[NOTE: the numbers represent the sequence of the commands as outputted from the 'history' command and were not actually typed for execution. Sorry for the confusion. =P]

ERROR:

CMake Error: The source directory "/Users/elliottapscott/Documents/Argos/argos3-examples/build" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

--------------------------------------------------------------------------------------------------------------------------------------
Next sequence of commands to work around error:

547 cd ..
550 mv CMakeLists.txt ./build/
551 cd build/
552 ls
553 cmake -DCMAKE_BUILD_TYPE=Debug

Produces following error:

-- The C compiler identification is AppleClang 8.1.0.8020042
-- The CXX compiler identification is AppleClang 8.1.0.8020042
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/cc
-- Check for working C compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/c++
-- Check for working CXX compiler: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/local/bin/pkg-config (found version "0.29.2")
-- Checking for module 'argos3_simulator'
-- Found argos3_simulator, version 3.0.0-beta47
-- Found OpenGL: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks/OpenGL.framework
-- Found GLUT: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.sdk/System/Library/Frameworks/GLUT.framework
CMake Warning at CMakeLists.txt:33 (find_package):
By not providing "FindGALIB.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "GALIB", but
CMake did not find one.

Could not find a package configuration file provided by "GALIB" with any of
the following names:

GALIBConfig.cmake
galib-config.cmake

Add the installation prefix of "GALIB" to CMAKE_PREFIX_PATH or set
"GALIB_DIR" to a directory containing one of the above files. If "GALIB"
provides a separate development package or SDK, be sure it has been
installed.


-- Found Lua52: /usr/local/lib/liblua.dylib
CMake Error at CMakeLists.txt:48 (add_subdirectory):
add_subdirectory given source "controllers" which is not an existing
directory.


CMake Error at CMakeLists.txt:51 (add_subdirectory):
add_subdirectory given source "loop_functions" which is not an existing
directory.


CMake Error at CMakeLists.txt:54 (add_subdirectory):
add_subdirectory given source "embedding" which is not an existing
directory.


-- Configuring incomplete, errors occurred!
See also "/Users/elliottapscott/Documents/Argos/argos3-examples/build/CMakeFiles/CMakeOutput.log".

(NOTE: FindGALIB.cmake is inside the cmake directory)
--------------------------------------------------------------------------------------------------------------------------------------

Attempting to "make" regardless of the errors fails and results in:
--> make: *** No targets specified and no makefile found. Stop.

--------------------------------------------------------------------------------------------------------------------------------------
Would you like to see the output of "CMakeOutput.log"?

pincy
Site Admin
Posts: 251
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: ERROR: Interceptors are not working.

Postby pincy » Sun Sep 24, 2017 3:54 pm

I wrote the correct commands already before. This is wrong:

537 sudo rm -r build/ && sudo rm -r experiments/

You're erasing the experiments/ directory and you should not.

539 git clone https://github.com/ilpincy/argos3-examples

This is wrong. You're cloning argos3-examples/ into argos3-examples/ again. This messes up the directory structure.

544 cmake -DCMAKE_BUILD_TYPE=Debug

This is wrong. You should write this instead:

cmake -DCMAKE_BUILD_TYPE=Debug ..

Notice the .. at the end.

Please, follow the instructions I gave you closely, and read the README. That's the correct approach. Don't try workarounds, because they'll make your life harder. You're working against the design. And please, take the time to learn CMake.

To be explicit once again, the correct list of commands is:

rm -rf argos3-examples
git clone https://github.com/ilpincy/argos3-examples
cd argos3-examples
mkdir build
cd build
cmake -DCMAKE_BUILD_TYPE=Release ..
make
cd ..
argos3 -c experiments/diffusion_1.argos

Any deviation from these commands is wrong.
I made ARGoS.

eptap
Posts: 9
Joined: Mon Sep 18, 2017 9:35 pm

Re: ERROR: Interceptors are not working.

Postby eptap » Sun Sep 24, 2017 5:04 pm

It works now following your commands exactly. Thank you for your patience with me. I'll be sure to read up on 'cmake' for future reference (since I didn't understand the ".." ending)


Return to “Bugs”



cron