Search found 35 matches

Go to advanced search

by mallwright
Tue Oct 15, 2019 9:51 am
Forum: How to... ?
Topic: Footbots moving in 3D space
Replies: 9
Views: 28494

Re: Footbots moving in 3D space

Do you have someone in mind? The E-puck may be older but it is still being used at our lab for research. The foot-bots are just collecting dust.
by mallwright
Mon Oct 14, 2019 9:37 am
Forum: How to... ?
Topic: Footbots moving in 3D space
Replies: 9
Views: 28494

Re: Footbots moving in 3D space

Sorry for the delay in replying. I had some issues with my account. Convex hull support is provided via the prototype entity as a link geometry. I haven't added it as a standalone entity. Support for this geometry isn't going anywhere, I just forgot to update the documentation. Regarding your requir...
by mallwright
Tue Oct 02, 2012 10:58 am
Forum: Bugs
Topic: Large number of objects using Dynamics3D causes SEGFAULT
Replies: 3
Views: 12914

Re: Large number of objects using Dynamics3D causes SEGFAULT

Hi Pincy, yes the boxes used for the walls do not overlap.
by mallwright
Mon Oct 01, 2012 1:46 pm
Forum: Bugs
Topic: Large number of objects using Dynamics3D causes SEGFAULT
Replies: 3
Views: 12914

Re: Large number of objects using Dynamics3D causes SEGFAULT

I have had variable results by decreasing the number of blocks, this sometimes shows the system coming to rest, and sometimes results in a SEGFAULT, which would be influenced by the value of the random seed. The version of ODE in use is 2:0.11.1-4build1 (precise), that is built for Ubuntu precise 64...
by mallwright
Mon Oct 01, 2012 1:34 pm
Forum: Bugs
Topic: Large number of objects using Dynamics3D causes SEGFAULT
Replies: 3
Views: 12914

Large number of objects using Dynamics3D causes SEGFAULT

In a configuration with a large number of objects (250 in this case), it appears that after the number of collisions reaches a particular threshold and causes CDynamics3D / ODE to throw a segmentation fault. See attached image and XML for the scenario, and the GDB inspection of the ARGOS during the ...
by mallwright
Fri Jun 15, 2012 9:29 am
Forum: Bugs
Topic: Suggestion: Template specialisation for CRange<CRadians>
Replies: 3
Views: 13064

Re: Suggestion: Template specialisation for CRange<CRadians>

The solution that I will implement will provide same functionality and will be transparent to the user of the API. The difference would be that I would compensate for things such that if a range given was between 10 and 30 degrees, and user ran the method CRange::WithinMinBoundIncludedMaxBoundInclud...
by mallwright
Thu Jun 14, 2012 3:07 pm
Forum: Bugs
Topic: Suggestion: Template specialisation for CRange<CRadians>
Replies: 3
Views: 13064

Suggestion: Template specialisation for CRange<CRadians>

Hi All, I've come across a problem in ARGoS that I am going to make a patch for, however I would like to get some feedback first. The patch will create a specialised version of the CRange template for types CRadians and CDegrees. Consider the following scenario to understand my motivation for this. ...
by mallwright
Thu May 31, 2012 2:22 pm
Forum: How to... ?
Topic: Sensing the speed of the footbot
Replies: 0
Views: 44851

Sensing the speed of the footbot

So, I have been taking readings from the FootBotEncoderSensor and the FootBotWheelSpeedSensor to see if I could detect when the footbot had collided with an object based on the change in speed. However both these sensors seem to only return the value that I set to the FootBotWheelActuator (or in the...
by mallwright
Sun May 27, 2012 1:02 pm
Forum: How to... ?
Topic: [SOLVED] Footbot Gripper Actuator
Replies: 4
Views: 16362

Re: Footbot Gripper Actuator

Hi Pincy, I have been doing some more work with the gripper, however I think my approach might be a bit off as when ever I make a call to the LockPositive or LockNegative function of the gripper, ARGoS crashes with an error from the chipmunk physics engine: Aborting due to Chipmunk error: This addit...
by mallwright
Fri May 25, 2012 2:35 pm
Forum: Feature Requests
Topic: ARGoS on Ubuntu 12.04 LTS
Replies: 16
Views: 41538

Re: ARGoS on Ubuntu 12.04 LTS

No worries Pinci, it's been awhile since I have run Argos using the package installation and had forgotten about the launch_argos script.

Cheers,

Mike

Go to advanced search



cron