Search found 38 matches

Go to advanced search

by mbt925
Wed Feb 13, 2019 1:23 pm
Forum: How to... ?
Topic: E-puck Light sensor range
Replies: 4
Views: 8000

Re: E-puck Light sensor range

Have a look here: https://github.com/ilpincy/argos3/blob/ ... ty.cpp#L35

In general, all the entity models contain the main measures.
Thanks. What is the unit? cm?
by mbt925
Wed Jan 02, 2019 12:54 pm
Forum: How to... ?
Topic: E-puck Light sensor range
Replies: 4
Views: 8000

E-puck Light sensor range

Hi,
I wanted to know the range of a specific sensor in ARGoS. For example the light sensor in e-puck. Where can I find that?
Thanks.
by mbt925
Wed Jun 20, 2018 6:15 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

I don't understand what you're trying to accomplish. The code you gave me has a number of issues. This is a sample project. I tried to recreate the issue of my main project in it. In the loop functions, you have a loop over all the epuck. Within this loop, you erase all of the boxes. Why? Looping o...
by mbt925
Sun Jun 17, 2018 7:16 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

Is there any problem in my code? :?:
by mbt925
Mon Jun 11, 2018 12:32 pm
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

Here is the code.

The source of segfault is the following line.

Code: Select all

m_pcCamera->Enable();
by mbt925
Mon Jun 11, 2018 11:38 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

Adding and removing entities are OK after omitting cLEDMedium.AddEntity() . Everything was fine until I added OmnidirectionalCamera sensor to my robots. The camera is not doing anything. I just turned it on and got segfault. m_pcCamera = GetSensor<CCI_EPuckOmnidirectionalCameraSensor>("epuck_omnidir...
by mbt925
Mon Jun 11, 2018 6:48 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

Thank you for the response. The code you sent me is not a precise copy-paste of what I gave you. You added an extra line: cLEDMedium.AddEntity(pcBox->GetLEDEquippedEntity().GetLED(0)); This line should not be there, because it adds the LED again to the medium. That task is already done by I suggeste...
by mbt925
Sat Jun 09, 2018 9:42 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

I upgraded my sample project . Now, it creates 100 boxes with led in Init method and removes and recreates them in Reset method. I did the following steps for getting the following segfault: 1. Run the simulation 2. Terminate it 3. Reset it 4. Repeat the whole process a couple of times Note: without...
by mbt925
Sat Jun 09, 2018 7:36 am
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

I noticed that you changed just the order of lines. Am I right?
by mbt925
Fri Jun 08, 2018 4:27 pm
Forum: How to... ?
Topic: Create multiple boxes with LED on top
Replies: 36
Views: 37681

Re: Create multiple boxes with LED on top

Thank you very much.I am sorry for the code. It was compiling and working just fine on my PC.

Please add the "ADDING LIGHT TO THE LED MEDIUM" part to your code too.

Go to advanced search



cron