Search found 48 matches

Go to advanced search

by AntonioC
Sat Jan 08, 2022 9:12 pm
Forum: How to... ?
Topic: No package 'argos3_simulator' found
Replies: 21
Views: 4549

Re: No package 'argos3_simulator' found

Is there an old version of Argos compatible with this repository?
by AntonioC
Sat Jan 08, 2022 12:05 pm
Forum: How to... ?
Topic: No package 'argos3_simulator' found
Replies: 21
Views: 4549

Re: No package 'argos3_simulator' found

I need a solution urgently please.
by AntonioC
Fri Jan 07, 2022 11:52 pm
Forum: How to... ?
Topic: error: unknown type name ‘namespace’
Replies: 1
Views: 7896

error: unknown type name ‘namespace’

Since the Kilobot does not have a physical position sensor I used the default position sensor that Argos provides. In the .argos file I wrote the following piece of code: <controllers> <kilobot_controller id="kbc"> <actuators> <kilobot_led implementation="default" /> </actuators> <sensors> <position...
by AntonioC
Fri Jan 07, 2022 6:30 pm
Forum: How to... ?
Topic: Symbol "kilobot" not found
Replies: 8
Views: 1824

Re: Symbol "kilobot" not found

I logged in as root and ran the commands you wrote me. Now everything works. Thanks so much. :D
by AntonioC
Fri Jan 07, 2022 5:23 pm
Forum: How to... ?
Topic: Symbol "kilobot" not found
Replies: 8
Views: 1824

Re: Symbol "kilobot" not found

antonio@antonio-Lenovo-V110-15AST:~/Downloads/argos3-kilobot-master$ sudo mv /usr/local/lib/argos3 /usr/lib [sudo] password for antonio: mv: cannot move '/usr/local/lib/argos3' to '/usr/lib/argos3': Directory not empty antonio@antonio-Lenovo-V110-15AST:~/Downloads/argos3-kilobot-master$ rm -rf /usr...
by AntonioC
Fri Jan 07, 2022 4:50 pm
Forum: How to... ?
Topic: Symbol "kilobot" not found
Replies: 8
Views: 1824

Re: Symbol "kilobot" not found

antonio@antonio-Lenovo-V110-15AST:~/Downloads/argos3-kilobot-master$ which argos3 /usr/bin/argos3 antonio@antonio-Lenovo-V110-15AST:~/Downloads/argos3-kilobot-master$ ls /usr/local/lib/argos3 libargos3plugin_simulator_kilobot.so libargos3plugin_simulator_kilolib.a antonio@antonio-Lenovo-V110-15AST:...
by AntonioC
Fri Jan 07, 2022 3:53 pm
Forum: How to... ?
Topic: Symbol "kilobot" not found
Replies: 8
Views: 1824

Re: Symbol "kilobot" not found

I downloaded the folder from: https://github.com/ilpincy/argos3-kilobot
And I ran the following commands:

Code: Select all

mkdir build cd build cmake -DCMAKE_BUILD_TYPE=Release ../src make sudo make install
by AntonioC
Fri Jan 07, 2022 2:36 pm
Forum: How to... ?
Topic: Symbol "kilobot" not found
Replies: 8
Views: 1824

Symbol "kilobot" not found

When I try to run the command:

Code: Select all

argos3 -c src/examples/experiments/kilobot_blinky.argos
The following errors appear:

Code: Select all

[FATAL] Failed to initialize the space. [FATAL] Symbol "kilobot" not found.
by AntonioC
Thu Jan 06, 2022 2:29 pm
Forum: How to... ?
Topic: GetX and GetY of Kilobot
Replies: 1
Views: 710

GetX and GetY of Kilobot

How can I detect the position of the Kilobots during the execution phase without using the ARK system? Is there a function or plugin I can use?
Eg:

Code: Select all

void loop(){ printf("K : %f %f\n", getX(), getY()); }
The simulator gives me problems if I try to use the ARK system with Kilobots.
by AntonioC
Sun Dec 19, 2021 4:26 pm
Forum: How to... ?
Topic: No package 'argos3_simulator' found
Replies: 21
Views: 4549

No package 'argos3_simulator' found

My Ubuntu version is 18. When I run the command cmake -DCMAKE_BUILD_TYPE=Release ../src the terminal prints the following text -- The C compiler identification is GNU 7.5.0 -- The CXX compiler identification is GNU 7.5.0 -- Check for working C compiler: /usr/bin/cc -- Check for working C compiler: /...

Go to advanced search



cron