Search found 65 matches

Go to advanced search

by Waqar731
Thu May 14, 2015 8:59 am
Forum: How to... ?
Topic: Problem with Multiple Loop Functions
Replies: 2
Views: 9556

Re: Problem with Multiple Loop Functions

thanks sir
by Waqar731
Wed May 13, 2015 10:55 am
Forum: How to... ?
Topic: Problem with Multiple Loop Functions
Replies: 2
Views: 9556

Problem with Multiple Loop Functions

Hi I am trying to use 2 loop functions in XML(.argos) file. But when i try to run the simulation then i get the error given below: std::bad_cast I am trying to add the multiple controller in this way: <loop_functions ................ /> <loop_functions ................ /> How can i fix the above err...
by Waqar731
Wed Mar 11, 2015 9:12 pm
Forum: How to... ?
Topic: Wheel rotation of mobile robot at 180 degree
Replies: 5
Views: 39783

Re: Wheel rotation of mobile robot at 180 degree

Hi, i fulfill the requirements to rotate the robot at any desired angle between [0,360] as you suggested already. (i) to use the wheels actuator. (ii) to make the same speed of both wheels. (iii) to use +ive and -ive speeds of both wheels. But my robot is not rotating greater than 30 degree? Followi...
by Waqar731
Wed Mar 11, 2015 8:58 am
Forum: How to... ?
Topic: Wheel rotation of mobile robot at 180 degree
Replies: 5
Views: 39783

Re: Wheel rotation of mobile robot at 180 degree

Hi I just want to do because i want to make my mobile robot rotate easily at any angle to any grid out of 8 adjacent connected grids at one time step. If it is not possible in reality, then how it is going on in flocking example in argos2 simulator. Why speed of one wheel is set to be +ive and other...
by Waqar731
Tue Mar 10, 2015 8:12 am
Forum: How to... ?
Topic: Wheel rotation of mobile robot at 180 degree
Replies: 5
Views: 39783

Wheel rotation of mobile robot at 180 degree

Hello to all I am trying to rotate the robot at 180 degree on single step of simulation out of three buttons. But robot only move maximum of 30 degree at each time step. The code is given below: Real fLeftWheelSpeed, fRightWheelSpeed; fLeftWheelSpeed = m_sWheelTurningParams.MaxSpeed; fRightWheelSpee...
by Waqar731
Mon Feb 16, 2015 2:42 pm
Forum: How to... ?
Topic: Problem in initialization of Array
Replies: 1
Views: 7151

Problem in initialization of Array

Hi, I have made arena of 10X10. I have made an array in header file. And initialize it with 0 in control step. Now when at each step of movement of robot, the values initialize again and again. What can i do now to avoid re-initialization again and again. void CFootBotDistanceScannar::ControlStep() ...
by Waqar731
Mon Feb 16, 2015 10:20 am
Forum: How to... ?
Topic: Unable to Simulate the Foraging Example
Replies: 0
Views: 74402

Unable to Simulate the Foraging Example

Hi I am trying to see how the foraging simulate, old one example build in argos2 simulator. But when i run the simulation, i get the following error. [FATAL] CARGoSException thrown: /home/pincy/Fabrica/argos2/simulator/dynamic_linking/dynamic_linking_manager.cpp:173 Error initializing loop functions...
by Waqar731
Sun Feb 15, 2015 9:46 pm
Forum: How to... ?
Topic: Segmentation Fault in running Simulation
Replies: 1
Views: 7686

Segmentation Fault in running Simulation

Hello, I have surrounded an arena of 10x10 boxes in Argos2 simulator. According to arena, i made an array of [10]X[10]. I write code for declaration of array in my header file as private attribute. Real DataStorageArray[10][10]; Then i iterate an array in my control step with code. for( int w=-2;w<=...
by Waqar731
Mon Jan 26, 2015 3:27 pm
Forum: How to... ?
Topic: Unable to Add New Class in Argos2 Existing Code
Replies: 4
Views: 12560

Re: Unable to Add New Class in Argos2 Existing Code

Hi,
"how to activate C++11" in builld in Argos2?
by Waqar731
Mon Jan 26, 2015 9:08 am
Forum: How to... ?
Topic: Unable to Add New Class in Argos2 Existing Code
Replies: 4
Views: 12560

Re: Unable to Add New Class in Argos2 Existing Code

Hi, Actually when i compile and run this code separately from argos code then it gives 100% correct result but when i tried using argos then it gives error. However, now i have even update the code as you suggest, but still having a problem. Code is given below: #include <iostream> class CCI_Point {...

Go to advanced search