Actual wheel velocity

Requests regarding how to set up experiments in ARGoS.
jtrautmann
Posts: 9
Joined: Thu Jan 30, 2020 11:29 am

Actual wheel velocity

Postby jtrautmann » Thu Nov 12, 2020 4:20 pm

Hello,

I'm using differential_steering actuator and sensor in my controller. Unfortunately I realized that the velocities for the wheels that the sensor returns are always those of the actuator. If the robot has to accelerate to reach the velocity given by the actuator and does not reach it in one tick, the sensor already returns the goal velocity and not the current one. Is there any easy way to get the actual wheel velocity?

Thank you in advance!

pincy
Site Admin
Posts: 550
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Actual wheel velocity

Postby pincy » Thu Nov 12, 2020 4:35 pm

It's a missing feature. Both the differential drive sensor and the actuator use the same attributes of CWheeledEntity to read/write their velocities.

https://github.com/ilpincy/argos3/blob/ ... r.cpp#L125

https://github.com/ilpincy/argos3/blob/ ... or.cpp#L65

https://github.com/ilpincy/argos3/blob/ ... tity.h#L71

The correct implementation would be to distinguish between actual and desired. I guess I'll have to fix this, I can't see a way to do what you ask without changing these classes.
I made ARGoS.

jtrautmann
Posts: 9
Joined: Thu Jan 30, 2020 11:29 am

Re: Actual wheel velocity

Postby jtrautmann » Fri Nov 13, 2020 1:45 pm

Okay, thank you for the reply! Is there any forecast when you could fix it?

pincy
Site Admin
Posts: 550
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Actual wheel velocity

Postby pincy » Wed Nov 25, 2020 9:36 am

Let me survive the semester (Dec 15) and then I'll fix that, along with a bunch of other things :-)
I made ARGoS.


Return to “How to... ?”



cron