Error initializing loop functions

Requests regarding how to set up experiments in ARGoS.
AntonioC
Posts: 48
Joined: Mon Aug 30, 2021 7:02 pm

Error initializing loop functions

Postby AntonioC » Tue Jan 18, 2022 3:45 pm

I used the ilpincy repository (https://github.com/ilpincy/argos3-kilobot).
When I go to compile everything is fine. When I go to perform some experiments they work. The only one that doesn't work is kilobot_trajectory.argos
When I run it I get the following error:

Code: Select all

antonio@antonio-Lenovo-V110-15AST:~/Desktop/argos3-kilobot-master$ argos3 -c src/examples/experiments/kilobot_blinky.argos [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_footbot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_spiri.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_dynamics3d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_eyebot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_epuck.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_genericrobot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_media.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_prototype.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_dynamics2d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_pointmass3d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_entities.so" [INFO] Loaded library "/usr/lib/argos3/libargos3core_simulator.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_qtopengl.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_kilobot.so" [INFO] Not using threads [INFO] Using random seed = 124 [INFO] Using simulation clock tick = 0.0322581 [INFO] Total experiment length in clock ticks = unlimited [INFO] The physics engine "dyn2d" will perform 10 iterations per tick (dt = 0.00322581 sec) antonio@antonio-Lenovo-V110-15AST:~/Desktop/argos3-kilobot-master$ argos3 -c src/examples/experiments/kilobot_trajectory.argos [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_footbot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_spiri.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_dynamics3d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_eyebot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_epuck.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_genericrobot.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_media.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_prototype.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_dynamics2d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_pointmass3d.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_entities.so" [INFO] Loaded library "/usr/lib/argos3/libargos3core_simulator.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_qtopengl.so" [INFO] Loaded library "/usr/lib/argos3/libargos3plugin_simulator_kilobot.so" [INFO] Not using threads [INFO] Using random seed = 124 [INFO] Using simulation clock tick = 0.0322581 [INFO] Total experiment length in clock ticks = unlimited [FATAL] Error initializing loop functions [FATAL] Can't load library "build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions" after trying the following: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: cannot open shared object file: No such file or directory ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: cannot open shared object file: No such file or directory /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: /usr/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory antonio@antonio-Lenovo-V110-15AST:~/Desktop/argos3-kilobot-master$
I went to check the build folder and the loop function folders are not created. I also checked some cmake files but they seem to be ok.

pincy
Site Admin
Posts: 603
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error initializing loop functions

Postby pincy » Tue Jan 18, 2022 5:40 pm

There's a mistake in src/examples/loop_functions/CMakeLists.txt file. I'll fix it today as soon as I have a little time!
I made ARGoS.

AntonioC
Posts: 48
Joined: Mon Aug 30, 2021 7:02 pm

Re: Error initializing loop functions

Postby AntonioC » Wed Jan 19, 2022 4:14 pm

When you have solved the problem will you tell me with an answer here on the forum?

pincy
Site Admin
Posts: 603
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error initializing loop functions

Postby pincy » Wed Jan 19, 2022 5:02 pm

It's fixed.
I made ARGoS.


Return to “How to... ?”



cron