Error when running kilobot_trajectory.argos

Discussions regarding ARGoS bugs. Report bugs here.
noran
Posts: 2
Joined: Mon Jun 07, 2021 3:20 am

Error when running kilobot_trajectory.argos

Postby noran » Mon Jun 07, 2021 11:34 am

Hello,

Trying to run kilobot_trajectory.argos results in this error:

Code: Select all

[FATAL] Error initializing loop functions [FATAL] Can't load library "build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions" after trying the following: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: cannot open shared object file: No such file or directory ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: ./build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions: cannot open shared object file: No such file or directory /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: /usr/local/lib/argos3/build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so: cannot open shared object file: No such file or directory
My OS: Ubuntu 20.04

pincy
Site Admin
Posts: 527
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error when running kilobot_trajectory.argos

Postby pincy » Mon Jun 07, 2021 12:20 pm

I don't think it's a bug, but I need more information to understand what is going on.
  1. Does the file build/examples/loop_functions/trajectory_loop_functions/libtrajectory_loop_functions.so exist?
  2. Do the other examples work?
I made ARGoS.

noran
Posts: 2
Joined: Mon Jun 07, 2021 3:20 am

Re: Error when running kilobot_trajectory.argos

Postby noran » Tue Jun 08, 2021 6:53 pm

1.The folders trajectory_loop_functions and debug_loop_functions that should be in argos3-kilobot/build/examples/loop_functions don't exist.

2. Examples that don't use loop functions works fine.

pincy
Site Admin
Posts: 527
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error when running kilobot_trajectory.argos

Postby pincy » Tue Jun 08, 2021 7:26 pm

So there's an issue with compilation. What's the output of the compilation process?
I made ARGoS.


Return to “Bugs”



cron