Simulations bring up blank black screen, or background terminal

Discussions regarding ARGoS bugs. Report bugs here.
pkg
Posts: 6
Joined: Sat Sep 05, 2015 4:37 am

Simulations bring up blank black screen, or background terminal

Postby pkg » Sat Sep 05, 2015 8:25 am

I installed Argos 64-bit binary on Ubuntu Trusty, and built the examples. Nonetheless, the simulations invoked by (for example)
$ argos3 -c ./experiments/diffusion_1.argos

shows a blank black arena with no objects at all. See attached image from screen capture tool.

Debugging:
When I do argos -q all, I get
==
AVAILABLE VISUALIZATIONS

[ qt-opengl ]
An interactive graphical renderer based on QT and OpenGL.
===

Problem remains with both Qt4 and Qt5.

I get this issue only on my new Dell XPS 13. The visualization works fine on Trusty on a Dell Precision desktop.

I suspect some package needs to be installed, though am unsure of what the problem could be.
Attachments
frame_00001.png
frame_00001.png (3.58 KiB) Viewed 9505 times

pkg
Posts: 6
Joined: Sat Sep 05, 2015 4:37 am

Re: Simulations bring up blank black screen, or background terminal

Postby pkg » Sat Sep 05, 2015 8:52 pm

Uncheck the "Anti-Alias" option under "Camera".

This fixed it completely.

pincy
Site Admin
Posts: 487
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Simulations bring up blank black screen, or background terminal

Postby pincy » Sat Sep 05, 2015 8:56 pm

Hi,

Thanks for telling me! I wonder what the problem might be. Unfortunately I don't own a machine that allows me to reproduce it, so it's pretty hard for me to fix the issue.

I'm happy there's a workaround - this way you're not blocked.

I'd like to ask you a few details on your machine:

1. Which graphics card do you have?
2. Which X11 driver do you use? Which version?

Thanks!

Cheers,
Carlo
I made ARGoS.

pkg
Posts: 6
Joined: Sat Sep 05, 2015 4:37 am

Re: Simulations bring up blank black screen, or background terminal

Postby pkg » Sun Sep 06, 2015 4:52 am

Graphics card:
VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
X11 driver : i915 from Intel

Is the X11 driver information what you expected? I got it from lshw -c video.

In addition, here's the info from xdpyinfo:

==
vendor release number: 11501000
X.Org version: 1.15.1
maximum request size: 16777212 bytes
motion buffer size: 256
bitmap unit, bit order, padding: 32, LSBFirst, 32
image byte order: LSBFirst
==

pincy
Site Admin
Posts: 487
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Simulations bring up blank black screen, or background terminal

Postby pincy » Sun Sep 06, 2015 4:16 pm

It might be quirks due to the Intel graphics driver. You wouldn't be the first one.

Thanks for the info - the first time I find a laptop with the same features, I'll try and fix the problem!

Cheers,
Carlo
I made ARGoS.


Return to “Bugs”



cron