Problem during installation of Argos3 on Mac

Discussions regarding ARGoS bugs. Report bugs here.
busca
Posts: 9
Joined: Thu Oct 17, 2013 1:08 pm

Problem during installation of Argos3 on Mac

Postby busca » Thu Oct 17, 2013 1:31 pm

Hi,
we try install argos3 from github on my MacBookPro 10.8.5, but i have some troubles with the installation of required software FreeImage 3.15.4.
in particular the problem comes out when i try compile FreeImage using make command.
we have downloaded from FreeImage's site the last version for Mac and we have changed the Makefile.osx after the first time we try to compile and came out an error about the gcc compiler and g++.
now we have that version of Makefile.osx :
https://github.com/sol-prog/FreeImage-OSX

can someone help me? is there any Mac's package for automatic installation????
thank you

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Problem during installation of Argos3 on Mac

Postby pincy » Thu Oct 17, 2013 2:18 pm

Hi busca,

the best way to install the necessary libraries on Mac is to use HomeBrew (http://brew.sh/). It does everything for you automatically.

Cheers,
Carlo
I made ARGoS.

busca
Posts: 9
Joined: Thu Oct 17, 2013 1:08 pm

Re: Problem during installation of Argos3 on Mac

Postby busca » Fri Oct 18, 2013 1:26 am

Hi Carlo,
i follow your suggestion and i have installed successfully all libraries needed (Thanks! ;) ), but when i try to compile argos3, following the guide lines in the readme file, comes out 3 error.

That's the error:

In file included from /Users/.../argos3/src/core/utility/math/rng.cpp:9:
/Users/.../argos3/src/core/utility/math/rng.h:231:10: error:
unknown type name 'random_data'
random_data* m_ptRNG;
^
/Users/.../argos3/src/core/utility/math/rng.cpp:69:21: error:
unknown type name 'random_data'
m_ptRNG = new random_data;
^
/Users/.../argos3/src/core/utility/math/rng.cpp:116:21: error:
unknown type name 'random_data'
m_ptRNG = new random_data;

^


thanks for your time!

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Problem during installation of Argos3 on Mac

Postby pincy » Fri Oct 18, 2013 10:36 am

Hi Busca,

Thanks for spotting this! I made a modification that should fix the problem.

To test it, erase the build/ directory and retry the compilation.

Cheers,
Carlo
I made ARGoS.

busca
Posts: 9
Joined: Thu Oct 17, 2013 1:08 pm

Re: Problem during installation of Argos3 on Mac

Postby busca » Fri Oct 18, 2013 11:47 am

Hi,

thank you so much! now argos3 seems like working! ;)

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Problem during installation of Argos3 on Mac

Postby pincy » Fri Oct 18, 2013 2:58 pm

Awesome! Thanks for trying ARGoS out :-)
I made ARGoS.

busca
Posts: 9
Joined: Thu Oct 17, 2013 1:08 pm

Re: Problem during installation of Argos3 on Mac

Postby busca » Wed Oct 23, 2013 4:58 pm

Hi!
that's unfortunately another problem when i try to compile the argos3 code on my mac..that's the error:

si-axel29:build andreabuscarini$ cmake ..
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
CMake Error at /usr/local/share/cmake-2.8/Modules/FindPkgConfig.cmake:319 (message):
pkg-config tool not found
Call Stack (most recent call first):
/usr/local/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
CMakeLists.txt:9 (pkg_check_modules)


-- Could NOT find GALIB (missing: GALIB_LIBRARY GALIB_INCLUDE_DIR)
CMake Error at CMakeLists.txt:19 (find_package):
By not providing "FindGSL.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "GSL", but
CMake did not find one.

Could not find a package configuration file provided by "GSL" with any of
the following names:

GSLConfig.cmake
gsl-config.cmake

Add the installation prefix of "GSL" to CMAKE_PREFIX_PATH or set "GSL_DIR"
to a directory containing one of the above files. If "GSL" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!


that's comes out when i execute the cmake command, after i have install correctly all the libraries and packages required.
Tomorrow i try to find myself a way to fix the problem, but if you have any idea it would be quickly! :)
Thanks for your time!

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Problem during installation of Argos3 on Mac

Postby pincy » Wed Oct 23, 2013 7:20 pm

Hi Busca,

for what I see in the output, you are missing the command 'pkg-config.' It is used by CMake to find ARGoS. Just install it through HomeBrew and the errors should disappear.

NOTE: remember to erase the build/ directory when you retry to compile. CMake constructs a cache of detected programs, and that cache must be removed for the checks to be repeated.

Cheers,
Carlo
I made ARGoS.

busca
Posts: 9
Joined: Thu Oct 17, 2013 1:08 pm

Re: Problem during installation of Argos3 on Mac

Postby busca » Thu Nov 07, 2013 10:18 am

Hi, i do that you suggest to me and something go in the right way... ;) but now comes out that error when i launch the cmake command:

-- The C compiler identification is Clang 5.0.0
-- The CXX compiler identification is Clang 5.0.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- GCC/G++ version >= 4.2
-- Could NOT find DLFCN (missing: DLFCN_INCLUDE_DIR)
CMake Error at cmake/ARGoSBuildChecks.cmake:17 (message):
Required library dl not found.
Call Stack (most recent call first):
CMakeLists.txt:36 (include)



thank you for your time!

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Problem during installation of Argos3 on Mac

Postby pincy » Thu Nov 07, 2013 10:50 am

Hi Busca,

That error is strange indeed. It means that CMake cannot find the library to load libraries dynamically (libdl.dylib).

Have you followed the instructions in the README? In particular:
On Mac, you can install all of the necessary requirements using HomeBrew. On the command line, type the following command:

$ brew install pkg-config cmake gsl libpng freeimage lua qt \
docbook asciidoc graphviz doxygen
Could you send the file build/CMakeCache.txt ?

Cheers,
Carlo
I made ARGoS.


Return to “Bugs”