Error while Compiling the ARGoS simulator

Discussions regarding ARGoS bugs. Report bugs here.
jaffar
Posts: 16
Joined: Fri Nov 28, 2014 9:50 am
Location: Abbottabad
Contact:

Error while Compiling the ARGoS simulator

Postby jaffar » Thu Mar 19, 2015 12:13 pm

Hi,
I install argos3. But when I compile ARGoS simulator so there is errors occured.

Code: Select all

size_t unLastBlobNum = lua_rawlen(pt_lua_state, -1); ^ make[2]: *** [plugins/robots/generic/CMakeFiles/argos3plugin_simulator_genericrobot.dir/control_interface/ci_colored_blob_omnidirectional_camera_sensor.cpp.o] Error 1 make[1]: *** [plugins/robots/generic/CMakeFiles/argos3plugin_simulator_genericrobot.dir/all] Error 2 make: *** [all] Error 2
How can I fix that errors.

Thanks

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error while Compiling the ARGoS simulator

Postby pincy » Thu Mar 19, 2015 1:13 pm

Hi,

Remove Lua 5.1 and install Lua 5.2.

Cheers,
Carlo
I made ARGoS.

jaffar
Posts: 16
Joined: Fri Nov 28, 2014 9:50 am
Location: Abbottabad
Contact:

Re: Error while Compiling the ARGoS simulator

Postby jaffar » Wed Mar 25, 2015 11:24 am

Hi

I remove lua5.1 and install lua5.2. Then I compile argos3 but it have still the same error. The error is in the file
ci_colored_blob_omnidirectional_camera_sensor.cpp
The following error occur.

Code: Select all

/home/jaffar/argos3/src/plugins/robots/generic/control_interface/ci_colored_blob_omnidirectional_camera_sensor.cpp: In member function ‘virtual void argos::CCI_ColoredBlobOmnidirectionalCameraSensor::ReadingsToLuaState(lua_State*)’: /home/jaffar/argos3/src/plugins/robots/generic/control_interface/ci_colored_blob_omnidirectional_camera_sensor.cpp:59:57: error: ‘lua_rawlen’ was not declared in this scope size_t unLastBlobNum = lua_rawlen(pt_lua_state, -1); ^ make[2]: *** [plugins/robots/generic/CMakeFiles/argos3plugin_simulator_genericrobot.dir/control_interface/ci_colored_blob_omnidirectional_camera_sensor.cpp.o] Error 1 make[1]: *** [plugins/robots/generic/CMakeFiles/argos3plugin_simulator_genericrobot.dir/all] Error 2 make: *** [all] Error 2
Thanks

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error while Compiling the ARGoS simulator

Postby pincy » Wed Mar 25, 2015 11:29 am

The error says that lua_rawlen is missing. This is a function defined in Lua 5.2 that was not present in Lua 5.1.

This means that Lua is not installed correctly on your system, because ARGoS still finds Lua 5.1.
I made ARGoS.

jaffar
Posts: 16
Joined: Fri Nov 28, 2014 9:50 am
Location: Abbottabad
Contact:

Re: Error while Compiling the ARGoS simulator

Postby jaffar » Thu Mar 26, 2015 1:27 pm

Hi,

I am trying to install lua5.2 again, as you that it is not installed correctally. But during installing lua5.2, instead of installing lua5.2 its output is lua5.2 is already installed.

Its means that lua5.2 is installed.

pincy
Site Admin
Posts: 512
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Error while Compiling the ARGoS simulator

Postby pincy » Thu Mar 26, 2015 3:05 pm

  • What does the output of CMake say when you launch it?
  • Why aren't you using a precompiled binary package?
  • On which system are you working?
I made ARGoS.

jaffar
Posts: 16
Joined: Fri Nov 28, 2014 9:50 am
Location: Abbottabad
Contact:

Re: Error while Compiling the ARGoS simulator

Postby jaffar » Tue Mar 31, 2015 2:13 pm

Hi,

I reinstalled argos3. Now it working properly.

Thanks


Return to “Bugs”