Foot-bot proximity sensor in 3D

Requests regarding how to set up experiments in ARGoS.
jharwell
Posts: 67
Joined: Thu Jan 25, 2018 4:12 am

Foot-bot proximity sensor in 3D

Postby jharwell » Tue Feb 25, 2020 1:10 am

Hi Carlo,

From my initial testing, the foot-bot proximity sensor seems to operate under the same assumption that the distance scanner does when you specifiy "rot_z_only", in that the foot-bot is assumed to be parallel to the XY plane. When I have the robot drive up one a shallow ramp, the rays shown by the proximity sensor do not seem to adjust as the robot moves up the incline, and soon hit the ramp itself, even though there are no obstacles in front of it.

Screenshot of what I'm seeing: https://drive.google.com/file/d/1Q9teEq ... sp=sharing

Is this the intended behavior? The docs with "argos -q" seem to imply that the proximity sensor respects the robot's current Z vector, as does the code, though I'm not an expert in robot kinematics, so I could be wrong. If this is the intended behavior, can the distance scanner be used instead of the proximity sensor with the "default" rather than "rot_z_only" implementation to detect obstacles as robots drive up ramps?

Thanks!

pincy
Site Admin
Posts: 637
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Foot-bot proximity sensor in 3D

Postby pincy » Wed Feb 26, 2020 7:26 am

I think this needs an answer from the person who did the 3D engine. I sent him a message.
I made ARGoS.

jharwell
Posts: 67
Joined: Thu Jan 25, 2018 4:12 am

Re: Foot-bot proximity sensor in 3D

Postby jharwell » Mon Mar 02, 2020 6:47 pm

Hi Carlo,

As part of my testing to with the dynamics3d engine, I found an initialization failure bug which I opened a pull request for (the <boundaries> tag is treated as a plugin). Very simple fix.

Any update on the proximity sensor?

- John

pincy
Site Admin
Posts: 637
Joined: Thu Mar 08, 2012 8:04 pm
Location: Boston, MA
Contact:

Re: Foot-bot proximity sensor in 3D

Postby pincy » Tue Mar 03, 2020 8:44 am

I contacted Michael Allwright twice and got no answer. Maybe try to contact him directly? The pull request should hopefully prompt him to dedicate some attention to this.
I made ARGoS.


Return to “How to... ?”